• Search
  • Register
  • Log in
  • Ace of Spades Game Forums » Help
  • Note: This forum is merely an archive. It is no longer possible to login or register. - StackOverflow
    New Ace of Spades Forums: http://buildandshoot.com/
  • How do you intall and use pyspades?
  •  

    Hey i have been scouring the internet for something to help me intall and use pyspades but i cant find anyone. Somone plz help!

    #48638
    Kitteh
    Member
    Posted 7 years ago
     

    There is not very much installing. All you really have to do is download the latest version from their site extract to somewhere modify the config.txt to your liking and run the run.exe

    Have you tried to run a normal server? if have did you get it working?
    Tell me a little more. are you having problems or just don't know what to do?

    #48683
    MegaDwarf
    I'm not that mean
    Posted 7 years ago
     

    Yes i have ran a normal server and it worked fine. But when i downloaded the latest version i didnt know anything about it and tried to modify the config txt best i could but when i ran it a cmd popped up and just went away.

    #49347
    Kitteh
    Member
    Posted 7 years ago
     

    Bump, because this happened to me too. And I can't go to #pyspades, because Hompy banned me from there for some BS reason.

    Edit: And this was the screencap of the cmd:
    http://i.imgur.com/ST65b.png

    #49433
    ReubenMcHawk
    Renovator
    Posted 7 years ago
     

    Yeah. i had the same thing.

    #49446
    Buffet_of_Lies
    Cartographer
    Posted 7 years ago
     

    do you need python installed to use it ? I dont think you would, but maybe that is the problem. i think it would probably be better if one of the developers told you, i don't know this program

    #49450
    Priok
    Spectonaut
    Posted 7 years ago
     

    You don't need Python installed. You should run run.bat so it gives you the exception (if any). ReubenMcHawk's problem was him, messing up the config, so recheck your configuration for mess-ups if you get an error like that.

    #49553
    mat^2
    pyspades developer
    Posted 7 years ago
     

    Ok i got the thing working because there was something wrong with the config but when i ran it it said something about pyOpenSSL not being intalled. I dont know if that has to do anything with it but after that it said something aboutthe server wont support SSL and then it connects. But a few seconds later it says disconneted from master server 20 sec. till reconnect.

    #50776
    Kitteh
    Member
    Posted 7 years ago
     

    Basically it disconnects then reconects over and over again?
    Thats what i have :(.

    #50853
    [C.H]Winston_
    Extreme Brit
    Posted 7 years ago
     

    Try downloading pyOpenSSL thats what i'm trying :)

    #50866
    [C.H]Winston_
    Extreme Brit
    Posted 7 years ago
     

    No ive already downloaded it and it still wont work.

    #50945
    Kitteh
    Member
    Posted 7 years ago
     

    Did you port forward? :L

    #50958
    MegaDwarf
    I'm not that mean
    Posted 7 years ago
     

    C:\Program Files\Ace of Spades\dist>run.exe
    Traceback (most recent call last):
    File "run.py", line 27, in <module>
    File "json\__init__.pyo", line 267, in load
    File "json\__init__.pyo", line 307, in loads
    File "json\decoder.pyo", line 319, in decode
    File "json\decoder.pyo", line 336, in raw_decode
    File "json\scanner.pyo", line 55, in iterscan
    File "json\decoder.pyo", line 183, in JSONObject
    File "json\scanner.pyo", line 55, in iterscan
    File "json\decoder.pyo", line 193, in JSONObject
    ValueError: Expecting , delimiter: line 92 column 2 (char 2767)

    C:\Program Files\Ace of Spades\dist>pause
    Press any key to continue . . .

    So annoying... I've looked through the config numerous times and I don't see anything there that would indicate a problem. Until then I'll just use the vanilla server.

    EDIT: Got it working... one small comma was missing from the welcomes section. Thanks Shams!

    #51069
    Buffet_of_Lies
    Cartographer
    Posted 7 years ago
     

    I think the error message is *very* explicit to be honest :P The config.txt file is a JSON file, and it even gives you the line you messed up at! Silly people :)

    Kitteh: either your ports are closed, or you're experiencing the 2-times master client connection bug. If the latter is the case, just let it reconnect for a while, it'll get there eventually.

    #51137
    mat^2
    pyspades developer
    Posted 7 years ago
     

    Ok ill try it

    #51179
    Kitteh
    Member
    Posted 7 years ago
     

    What's the 2-times master client connection bug?

    #51262
    MegaDeuce
    This is not a title.
    Posted 7 years ago
    RSS feed for this topic  

    Reply

    You must log in to post.

  • Tags
  •  

  •  
    Ace of Spades Game Forums is proudly powered by bbPress.   //   Theme by Mike Lothar  
    [ Time : 0.030s | 13 Queries ]